Thanks philipp, That solved the issue, although I do want to mention a couple things for the benefit of other people searching about this issue, as of this writing: - The Update Now button on the firefox plugin check page takes you to the download for 16.0.0.287, not 16.0.0.296 (I don't know if that is a Firefox problem or a Adobe problem) Somebody somewhere needs to fix this crack that things are falling through.- the download link in philipp's post takes you to a page which does not appear to have 16.0.0.296.Firefox Plugin Check says that 16.0.0.296 is vulnerable and needs to be updated.

adobe flash constantly updating-40

Also if you do the manual download process in the Chosen Solution above, it doesn't work this time, because this time that doesn't get you a newer version.

Why is FF able to tell me that Flash is not up to date but not able to help me update it? Only this time the above solution doesn't work.

Could FF instead grey out the "update now" unless/until there's a patch available?

And, even better, give some indication of what action they should take instead while a patch is (hopefully) being developed, and alert people when the patch is then ready for download?

I have a problem, I instaled Windows 8.1 and everything is great.

I have one problem, few times a day Adobe Flash player installer ask me to update it, and every time i do update it it start downloading update and it show Update cant be done check if you are conected to internet, i am going crazy with that, i uninstaled Flash player, i blocked it in Firewall after it and it still ask to update, even i dont have it any more on my pc...

Could FF instead grey out the "update now" unless/until there's a patch available?

Respectfully, /Will Sadkin Ah yes, I noticed that in another thread after posting that reply, sorry.

Read this answer in context hello, adobe has released a critical patch to mitigate yet another vulnerability in its flash plugin, which is reportedly already exploited in the wild.

Thanks philipp, That solved the issue, although I do want to mention a couple things for the benefit of other people searching about this issue, as of this writing: - The Update Now button on the firefox plugin check page takes you to the download for 16.0.0.287, not 16.0.0.296 (I don't know if that is a Firefox problem or a Adobe problem) Somebody somewhere needs to fix this crack that things are falling through.

But when you click on Windows Plugin-based browsers Download EXE Installer, it downloads .296, not .287 (and due to vague file naming you can't even know that till after you install it).